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Welcome To EverWeb! 
 

EverWeb is a complete drag and drop website building tool, letting you create 
professional, fast loading websites without any technical knowledge or coding 
skills. 

EverWeb not only makes it easy to create a website, but it also allows you to 
enhance your website with advanced widgets. You can use a widget to add E-
commerce features, Google Maps, Contact Forms, Facebook Like buttons and 
much more. 

EverWeb includes one click publishing to get your website online as fast as 
possible.
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Figure 1: EverWeb’s User Interface is clean and simple, EverWeb makes it extremely easy for anyone to build 
a beautiful website.
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EverWeb Standalone or EverWeb + 
Hosting 

EverWeb comes in two versions: 

EverWeb Software Only (Standalone) 
EverWeb Software + Hosting 

Important 
No matter which version you choose to buy you will never lose access to the license you 
purchase, even if you do not renew your account. EverWeb is NOT a subscription service. 
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EverWeb Software Only (Standalone) 
EverWeb Standalone includes EverWeb software and one year of product 
updates and support.  

If you do not wish to purchase another year of upgrades and support, you can 
still use the version of EverWeb that you have already purchased. 

With EverWeb Standalone you will have to purchase web hosting separately. 

EverWeb Standalone costs $79.95 per license. 
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EverWeb Software + Hosting - starting at $99.95 USD/year 
EverWeb + Hosting comes with the benefit of improved support and 
organization because everything related to your website goes through one 
company. EverWeb + Hosting also comes with these exclusive features: 

1. Password protection of your entire, or parts, of your website 

2. 404 Page Not Found redirects so your visitors won’t see 404 error pages 
if they visit and outdated link 

3. 301 redirects to redirect old web pages to your new EverWeb website 
and retain your search engine rankings 

4. Free software updates with an active account 

5. 24/7 Phone & Email Support with an active account 

6. Free Website Stats 

7. Faster Website previews and publishing 

8. SSL Certificate available 

The EverWeb + Hosting version also lets us more efficiently help you should 
problems arise because we have access to the server that your website is on. 
You only have to deal with one company for any of your website issues. 

EverWeb + Hosting starts at $99.95 USD/year.  
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EverWeb Site Shield Addon 
Protect your website and improve your Search Engine Ranking with EverWeb 
Site Shield.  

Google and other search engines give a Search Engine Ranking boost to 
websites that use HTTPS instead of just HTTP. 

Websites using HTTPS display a secure padlock symbol in their web browser’s 
path bar. 

The Importance of HTTPS 

Using HTTPS is important for your website as: 

• All data is ‘End to End’ encrypted from your visitors computer to your 
website 

• Your website is safer for your visitors 

• Your website’s credibility increases 

• Google and other search engines place HTTPS websites higher in their 
rankings than HTTP websites. 

Switching from HTTP to HTTPS can be a difficult process but EverWeb Site 
Shield includes automatic HTTPS secure websites with just one check box tick, 
giving you an HTTPS website that is highly optimized for search engines and 
protects your website visitors.  

EverWeb Site Shield is exclusive to EverWeb + Hosting accounts. EverWeb 
Standalone users must work with their web hosting provider to set this up. 

EverWeb Site Shield is included free if you have an EverWeb + Hosting 10GB or 
higher plan. 
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If you have an EverWeb + Hosting 2GB plan you can purchase EverWeb Site 
Shield for just $29.95 USD/year. 

Adding EverWeb Site Shield Addon 

To add EverWeb Site Shield Addon follow these steps or click this direct link; 

1. Login to your Client Area 

2. Select ‘Services’ from the menu and click on ‘View Available Addons’ 
from the navigation bar 

3. You will see the available ‘Add Ons’ on the next page in the ‘Product 
Addons’ section of ‘Categories’. 

4. Select the ‘Addon’ and follow the purchasing steps. 

Enabling HTTPS Websites with EverWeb 

To use EverWeb Site Shield on your website, simply go to the Site Publishing 
Settings of your website project file (using the File -> Edit Publishing Settings 
menu option) and tick the‘Use HTTPS Secure URLs’ box. 

EverWeb will take care of the rest when you publish your website.  

It is recommended that you publish your entire website (using the File -> 
Publish Entire Site menu option) as when this option is selected, some link 
structures in your website will need to be re-published. 
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Purchasing EverWeb 
Quickly and easily purchase EverWeb by following the link below. Licenses are 
immediately delivered so there’s no wait in getting your website online! 

Purchase an EverWeb License 
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Getting Started: The Projects Window 

The Projects Window is the first screen you see when you launch EverWeb (see 
Figure 2). 

The Projects Window is where you: 

• Create new website projects 

• Access the website projects you are currently working on 

• Perform administration tasks relating to your website project files. 
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Figure 2: The Projects Window can be accessed from the File -> Projects menu. It lists your current websites 
and lets you create new websites.
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Creating a New Website Project 
You can use the Projects Window to create a new website. The Projects 
Window has two buttons on left hand side: 

• ‘Create a new website’: Click this button whenever you want to create a 
new website project in EverWeb 

• ‘Learn How to use EverWeb’: A library of EverWeb video tutorials. 

The right hand side of the Projects Window shows the website project(s) that 
you have already created in the‘Recent Projects’ list. If you do not have any 
saved projects, the ‘Recent Projects’ list will be empty. 

Opening an Existing Website Project 
To open a saved project, simply double click on the its name in the ‘Recent 
Projects’ list. 

Deleting a Website Project 
If you want to delete a a website project, click on the project file in the ‘Recent 
Projects’ list and press the Delete key on your keyboard. You will be asked to 
confirm that you want to delete the project file or to cancel the operation. 

Alternatively, click on the up/down arrows next to the project name in the 
‘Recent Projects’ list, and select the ‘Delete…’ menu option. You will be asked to 
confirm that you want to delete the project file or to cancel the operation. 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Getting Help 
Help is available at any time in EverWeb.  

To access video tutorials either use the ‘Learn how to use EverWeb’ button on 
the Projects Window, or use the Help-> Video Tutorials menu.  

Video tutorials relating to specific EverWeb features are shown by 
the Video Help ‘?’ button next to the feature. Just click on the ‘?’ 
button to access the feature you want help with. 

If you want to access this User Manual at any time, click on the ‘EverWeb 
Manual’ link below the buttons on the Projects Window, or use the Help-> 
EverWeb Manual menu. 

If you cannot find the help you need, or have a question about EverWeb that is 
not covered in this manual, or in the video tutorials, please use one of the 
following resources: 

• The EverWeb website at www.everwebapp.com. 

• The EverWeb Knowledgeable at http://billing.ragesw.com/
knowledgebase.php 

• The EverWeb Discussion Forum at http://billing.ragesw.com/forum.php 

If you have a valid support plan you can also call, email or chat with an 
EverWeb Expert, live, 24 hours a day, seven days a week, 365 days a year at 

EverWeb Support: 1-888-500-2901  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The EverWeb User Interface 

Before starting to build your website, it is important to become familiar with 
EverWeb’s user interface (see Figure 3). 

On the left hand side of the window (see Figure 3 - Section A), is where all of 
your website's pages will appear. You can adjust the width of this area by 
hovering your cursor over the divider, and then clicking and dragging to the left 
or right. 

Tip: To rename a page, or your website name, select the page you want to rename and press 
the ‘Return’ key on your keyboard. Page names should only contain letters and numbers. Any 
spaces will be converted to a ‘-’ when publishing. 
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Figure 3: EverWeb’s User Interface consists of four main sections. Not pictured are the Assets and Widgets 
windows, which can be accessed by clicking on the tabs labeled Assets and Widgets respectively.
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At the top of the window is the Toolbar (see Figure 3 - Section B) which allows 
you to quickly do tasks such as add a new page, shape, or text box. 

On the right hand side, is the Inspector Window (see Figure 3 - Section C) 
which has three tabs containing all of the features to modifying elements of 
your website: 

• The Inspector tab, shown in Figure 3, allows you to control Page 
Settings, Shape Options, Object Metrics, Text properties, Hyperlinks and 
Widget settings. 

• The Assets tab is used for managing your website's images and media 
files. 

• The Widgets tab contains mini apps known as ‘Widgets’ for easily 
adding extra features you may want to your website.  

We’ll explore the Inspector Window and its tabs in detail later on. 

The area in the middle of the User Interface is the Editor Window which is your 
design canvas (see Figure 3 - Section D) where you will create or modify your 
web pages. 
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Positioning Objects in EverWeb’s Editor Window 
As EverWeb is a drag and drop website builder you can design your entire 
website just by dragging and dropping content: text, images, shapes and 
widgets on to its design canvas which is known as the Editor Window. 

The Editor Window 
EverWeb’s Editor Window has three main sections: 

• The Header 

• The main body (content) area 

• The Footer. 

Objects placed within the Header and moved down will adjust the top position 
of objects placed within the main body and Footer areas. Likewise, objects 
added to the main body area will adjust the top position of the Footer objects 
as they are moved down. 

This approach allows you to design each section of your page while making 
sure enough room is provided for the Header, content and Footer. It also 
prevents you from having to re-arrange objects each time you want to modify 
these sections. This becomes extremely useful when using Master Pages as 
described in the next section. 

By default, EverWeb displays the section borders in the Editor Window. You can 
toggle the display of these borders on or off using the Window ->Show Layout 
menu option.  

To explicitly adjust the height of each section go to the Inspector tab (see 
Figure 3 - Section C). Select the Page Settings button, then use the Page Layout 
section to change the section height. 
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As you add objects to each section, their height will adjust to accommodate 
the objects. In essence, the settings in the Inspector set the minimum height 
for each section. 

Adding and Moving Objects Around the Editor Window 

You can start working on your web page by, for example, adding a Text Box or 
Shape from the Toolbar. The Text Box or shape will be created in the main body 
of EverWeb’s Editor Window.  

To move the object just click and drag it around the Editor Window. Notice that 
the main content area’s height automatically adjusts when you approach the 
bottom border of a section. 

Moving Objects Between Editor Window Sections 

To move objects between sections, for example, from the main body into the 
Footer area, hold down the COMMAND key on your keyboard as you drag the 
object into another section. Release the COMMAND key and you’ll notice the 
object is now ‘trapped’ in the next section. 

If you don’t want an object to be able affect the height of a section go to 
Inspector->Metrics and select the ‘Allow free dragging’ option. Now the object 
can be dragged anywhere on the Design Canvas without affecting the height 
of each section. 
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Moving Obscured Objects 

As you design your web pages, you may sometimes have one or more objects 
overlapping other objects. To easily move an object that is covered without 
affecting covering objects: 

1. Select the object you want to move.  

2. If you have difficulty selecting the object you want, secondary click on 
the object that covers the object you want to select. 

3. A sub menu appears. Scroll down to the Pick Layer option. This will 
show you all of the objects that are positioned at the location you 
clicked on. 

4. Select the object you want from the list. Your object is now selected. 

5. Next, hold down the Command+Option keys and drag the object you 
want to its new location. 

Moving Objects Down the Page Whilst Retaining the Page Layout 

There may be times where you want to insert an object, e.g. an image, on to 
your web page but you need to create the space on your page in order to drop 
the image in place.  

To make the space for your image on the page, you may need to move existing 
content down the page in order to drop the image in to the right place  

EverWeb allows you to easily move the objects below where you want the 
image down all at the same time, so preserving the page layout 
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1. Select the first object that is directly below where you want to insert 
the image. 

2. Hold the Shift+Command keys down and drag the object down the 
page. 

3. The selected object, and all objects below it, will move down the page 
at the same time preserving the page layout. 

4. Once you have created enough space, release the keys and mouse then 
drag and drop the image in to the space you have just created. 

If you use the Shift+Command keys whilst resizing an object, the objects below 
the selected object will move down. 

Finding The Distance Between Objects 

When designing your web page, sometimes it is useful to find the distance 
between objects on the page. To do this 

1. Select the source object 

2. Hold the Option (Alt) key down. 

3. Mouse over the target object(s) to see the distance in pixels between it 
and the source object. 

.  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Starting A New Website 
You can begin a new website by clicking on the 'Create a new website' button 
on the Projects Window (See Figure 1 above). 

EverWeb's Theme Template Chooser will appear (see Figure 4).  

Choose a Theme Template from the list on the left. If you already know the 
name of the Theme Template you want to use, just start typing its name e.g. 
‘Wedding’. As you type, EverWeb will use predictive search to take you to the 
theme as you type. 

Click on the Theme Template you want to use in the left column, then select 
the page style you want from the right hand side.  
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Figure 4: The Theme Template window is where you select the page style that you want to use for your website. 
If you are building your websites from scratch use the Blank template.
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If you plan on building your website from scratch, use the Blank template 
which is the first theme in the list of Theme Templates. 

Click the ‘Select’ button to add the page to your website Project. 

Some Theme Templates use Google Fonts e.g. the Apollo theme. When the 
Theme Template downloads, you will be asked if you would like to use the 
Google Fonts that belong to the theme. It is recommended to do so. 

Adding New Theme Templates 
From time to time, new Theme Templates are added to EverWeb. To see if new 
Theme Templates are available use the EverWeb -> Check for New Templates 
menu option. 

Any new Theme Templates are marked with a ‘New’ indicator in the Theme 
Templates list (see figure 4). 
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Adding Pages To Your Website Project 
When you create a new website project, you also add the first page of the 
website using the Theme Template Chooser.  

To add more pages to your website click on the ‘Add Page’ 
button in the Toolbar. Select the new page theme and page 
style that you want to add as described above. 

The new page will appear in the Web Page List. 

If you want to add a page that looks identical to one of your pages, secondary 
click on the page name in the Web Page List that you want to copy, and select 
‘Duplicate’ from the menu.  

Duplicating a page is essentially copying an entire page.  

If most of your pages follow a similar design, consider using the Master Pages 
feature which is discussed later on in the User Manual. 
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Creating a Navigation Menu 
EverWeb’s Web Page List is used as the basis for your website’s Navigation 
Menu. The order of the pages in the Web Page List from top to the bottom 
determines the order that your Navigation Menu items are displayed from left 
to right. 

You have three different styles of Navigation Menu styles to choose from for 
your website: 

• A Simple Navigation Menu 

• A Dropdown Navigation Menu 

• A Responsive Navigation Menu 

Note: When we mention ‘Navigation Menu’ we are referring to EverWeb’s built in Navigation 
Menu widget. The Navigation Menu widget itself is discussed in detail later on. 

Only pages that have ‘include page in navigation menu’ ticked in the Page 
Settings of the Inspector Window are included in the Navigation Menu. 

Adding the Navigation Widget To Your Page 

For all menu styles, you add the Navigation Menu to your page in the same 
way. Select the Widgets Tab and drag and drop the Navigation Menu widget 
on to the page. Usually the widget is placed in the Header section of your 
Master page. Please refer to the Master Pages section for more information 
about how to create ‘template’ Master Pages for your website. 
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Creating a Simple Navigation Menu 
When you add the Navigation Menu widget to your page you will see that it 
includes all the pages from the Web Page List that have ‘include page in 
navigation menu’ ticked. 

The above example is a Simple Navigation Menu as all the menu options are on 
one line only. As you can see, this menu style may have too many items in it to 
be easy for your visitors to use (see Figure 5).  

It may be better to simplify the Navigation Menu by structuring the menu so 
that it includes dropdown items instead. 
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Figure 5: Navigation menu in EverWeb. Note the links for “For Sale” and “For Rent”
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Creating a Dropdown Navigation Menu 
In EverWeb you can create directories that can contain your web pages. Using 
directories is a good way to organize your website pages. It also keeps the 
Navigation Menu easy for your visitors to navigate 

The directory structure is also used to generate Dropdown Navigation Menus 
(see Figure 6). 

. 

Adding Directories To Your Website Project 

To add a directory to the Web Page List: 

1.Click on the ‘Add Directory’ button in the Toolbar. 

2.Select the Theme Template you want to use from the left 
hand column. 

3.Select the page style that you want to use from the right hand 
side of the Theme Template Chooser.  

4.Click’ Select’ to add the directory page to the Web Page List.. 

The new page has a folder (directory) icon instead of the normal page icon. 
Remember, the directory page is still a page on your site, so you will need to 
treat it like any other page. 
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Figure 6: Drop-down navigation menu in EverWeb. The “For Sale”  & “For Rent” links are now in a drop-down menu.
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To add pages within this directory, simply select the directory in the Web Page 
List, and click on the ‘Add Page’ button. A page is created within the directory 
and is displayed below, and a little to the right of, the directory, 

If you hover your mouse over the directory page in the Navigation Menu in the 
Editor Window, you will see the dropdown menu displayed. 

Moving Pages In and Out of The Directory 

You can move existing pages in and out the directory you have created. To 
move a page in to a directory. Click and drag the page you want to move and 
drag it on the directory folder. When you see a line with circle at the left hand 
end positioned just below and to the right of the folder, drop the page in place. 

If the folder is closed, you will not see the page placed in the folder. To open 
the folder to see its contents, click on the arrow to the left of the folder name. 

When the folder is open you can move pages out of the folder. Just click and 
drag the page you want out of the folder and to its new location and drop in 
place. 
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Creating a Responsive Navigation Menu 
Both Simple and Dropdown Navigation Menu 
styles can be incorporated in to a Responsive style 
Navigation Menu. 

A Responsive Navigation Menu will adapt to the 
width of the device you are using e.g on a desktop 
you will probably want to see a Simple or 
Dropdown Navigation Menu. On a mobile device 
where space is limited you may want to use a 
‘Hamburger’ style Navigation Menu instead. 

To see how this works:  

1. Add the Navigation Menu widget to your 
page. 

2. With the widget selected, go to the 
Widget Settings tab in the Inspector 
Window. (see Figure 7) 

3. Scroll down to the Responsive Options 
section. 

4. Tick the box for ‘Responsive Navigation 
Bar’. 

Notice that beneath ‘Responsive Navigation Bar’ 
is the option ‘Appear at Width’ which by default 
is set to 700. This means that when the screen 
width is less than 700 pixels, the Navigation 
Menu will become a Hamburger style menu. 

You can test this out by resizing the width of the EverWeb application. Click 
and drag the right hand edges of the EverWeb UI to the left. At 700 pixels wide, 
you will see the Navigation Menu change to a Hamburger style menu. 
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Figure 7: Navigation Menu Widget 
Settings showing Responsive 

Options.
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Formatting The Navigation Menu 
By default, the Navigation Menu label for each page is its ‘File Name’ as shown 
in the Web Page List and in the Page Settings tab of the Inspector Window. 

As File Names can only consist of letters and/or numbers, use the Navigation 
Display Name field in the Page Settings tab of the Inspector Window to 
override the File Name label in the Navigation Menu. You can use any label you 
want for the Navigation Menu. 

There are many ways in which to customize the Navigation Menu. First select 
the widget, then: 

• Change the Navigation Menu font and style using the Text tab in the 
Inspector Window or by using the Fonts button in the Toolbar. 

• Change the background appearance of the top level menu items using 
the ‘Fill’ section of the Shape Options tab in the Inspector Window. 

• Use the Widget Settings tab to change the background colors of 
dropdown menu items. 

• For a Responsive Navigation Menu, go to the Widget Settings and tick 
the ‘Responsive Navigation Bar’ option. You can now set when to have 
the Hamburger menu icon displayed. By default this is set at a width of 
700px. Change the Responsive Options and Hamburger Button 
options as desired. The options also allow you to change the 
Hamburger icon color and background as well as the menu label and 
its font style, size and color. 
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Master Pages 

EverWeb supports Master Pages so that you can design your website once and 
have all your pages use that design. When you want to make a change to your 
design, simply edit your Master Page and all pages that use that Master Page 
will be automatically updated. 
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Figure 8: Quickly add a Master Page to your website using the ‘New Master Page’ button.
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Creating a Master Page 
To create a Master Page, drag the splitter bar at the top of your Web Page List 
down to reveal the Master Pages list if you cannot see it.  

Click on the ‘New Master Page’ button (highlighted in Figure 8) to bring up the 
Theme Template Chooser, and add the page you want to use as a Master Page 
in the same way that you would for a regular page. 

Creating a Master Page is just like creating a regular page. You can design it 
however you like, adding shapes, text or images. 

You can have as many Master Pages as you want. For example, you can create a 
Master Page for your desktop site and another for your mobile site. 

Note: You cannot make a Master Page from the ‘blog’ Theme Template. 
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Using Master Pages 

Once you have created your Master Pages, you need to assign them to your 
web pages. 

To do this, select your page in the Web Page List on the left hand side.  

In the Inspector Tab on the right hand side, select the Master Page you want to 
use for that page as shown in Figure 9. 
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Figure 9: To add a Master Page to your web page, select it from the drop down menu in the Page Settings tab as 
shown above.
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The web page will now reflect the design of the Master Page. You can also add 
new shapes, text or images to the web page to enhance the design of 
individual pages. 

To quickly see which objects are part of the Master Page, and which are part of 
the web page you are working with, use the Window-> Show Layout menu. 

  

Objects that belong to a Master Page have a small, black page icon 
next to them and can only be edited from the Master Page itself. 

When working with Master Pages you will usually want to design the Header 
and Footer sections of your page and fill in the actual content on each 
individual page. In most cases, the content height will be different for each 
page. 

For your Master Page, you can set a small Content Height under Inspector-> 
Page Settings-> Page Layout section. Then, on your actual pages, any content 
you add will push the height the content area down. In this way, you can fit any 
amount of content in to your actual pages. 

You’ll notice that you can’t explicitly set the content height of each page that 
uses a Master Page. As noted above, as you add objects to the content area of 
your actual pages, the content area will expand to a longer size to 
accommodate them. 
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When working with Master Pages, remember to: 

1. Set the Content Height to something small, e.g. 100 pixels. Basically the 
minimum height any of the actual pages will be that use this Master 
Page. You can do this from the Inspector-> Page Settings-> Page Layout 
section. 

2. Use your Master Page to design a common Header and Footer for each 
of your pages. 

3. You can have multiple Master Pages. For example one for desktop 
pages and one for mobile pages 

4. You can’t explicitly set the height of each section on the actual pages 
that use your Master Page. Objects that you add to each section will 
adjust the height as needed to accommodate them, allowing you to 
pages with dynamic heights while still sharing the same Master Page 

5. Use the Window-> Show Layout menu to quickly see which objects are 
from your Master Page. They will have a small, black file icon in the top 
right corner. You must edit the Master Page to adjust any of these 
objects. 

Tip: Objects from the Master Page cannot be moved or altered from the child page. You will 
have to go back to the Master Page to make any changes to its design. 
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The Web Page List 

On the left hand side of EverWeb’s User Interface, you will see the name of your 
website project and any directories and web pages you have created listed 
beneath it (Figure 10). 

Each page or directory that you create has an icon next to it: 

A white icon indicates that the page, or directory, has not been modified 
since the last time you published the site. 

A red icon indicates that the page, or directory. has been modified since 
the last publish and will need to be published again for the changes to 
be reflected online. 
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Figure 10: The Web Page List is located on the left hand side of the application. Red icons indicate a modified 
page, a grey icon indicates no modifications have been made.

http://www.everwebapp.com


EverWeb User Manual The Web Page List

Naming Your Website Project, Directories and Pages 
You can change the name of your website, directories and web pages in a 
number of different ways: 

Double clicking with Mouse or Trackpad 

Double click on the website name, directory or page name in the Web 
Page List. Edit the name and press enter to finish. You can also use 
double click to rename blog post names and assets in the Assets List. 

Using Menu Options 

In addition to double clicking, you can use the File-> Rename Website 
menu option to rename your website. 

Use the File-> Rename menu option to rename the currently selected 
directory or web page that is currently selected. You can also use this 
menu options to rename assets and blog entries. 

The Inspector Tab 

Web pages and directories can also be renamed by clicking on the Page 
Settings button in the Inspector tab, then changing the page name 
using the ‘File Name’ option. 
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The Toolbar 

The Toolbar (see Figure 11) lets you quickly access common tasks such as 
adding new pages, shapes or text, change text fonts and more.  

• Add Page: Opens the Theme Template Chooser and lets you add a new 
page to your website based on a template or with a blank page 

• Add Directory: Directories are folders containing web pages. They are 
used to organize your website and for drop down navigation menus. 

• Preview: Preview your website in different web browsers. 

• Publish: This button publishes your website. Please refer to the 
Publishing section for more information. 

• Text Box: The button lets you add text to your page. Text can be 
formatted and positioned anywhere on your web page. 

• Shapes: EverWeb’s built in Shapes help you design your website. 
Shapes can have solid colors, gradients or images. See the Shape 
Options section for more information about customization options. 

• Scroll Position: Easily set up ‘anchors’ so you can hyperlink from any 
object to a specific location on any page in your website. See the 
section on Hyperlinking Objects for more information. 

• Rotate: This option rotates the selected shape 90 degrees clockwise. 
Hold down the option key to rotate the shape counter clockwise. 

• Mask: Allows you to quickly crop an image. 

• Fonts: The Fonts button will open up the Font panel and let you modify 
the selected fonts of any selected text box. 

• Colors: The Colors button opens the Color Picker and lets you change 
the text color of any selected shapes. 
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Figure 11: The Toolbar gives you quick access to frequently used features
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• Media: Allows you to access EverWeb’s Media browser.  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The Inspector Window 
Page Settings 
Page Details 
The first tab in the Inspector Window is 
the Page Settings tab. Here is where 
adjustments to the settings for each 
page on the website are made.   

The first option on the Page Details tab 
(Figure 12) is ‘File Name’.  

The File Name is what you see in your 
web browser's address field. e.g. you may 
want to name the page  after its function 
such as Home, About Us, Contact Us, 
Services, Products, etc.  

As you change the File Name, the 
changes also appear in the Web Page 
List.  

The page’s File Name is one of the topics 
discussed in the SEO For EverWeb Video 
Course. 

If Search Engine Optimization is important for your website, please look at the 
tutorials before assigning your web page's file names. 
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Figure 12: The Page Details section on the Page 
Settings tab.
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The ‘Language’ drop down is used for Search Engine Optimisation (SEO) 
purposes. For example, if your website is designed for Canadian visitors only, 
you may have most of your pages in English but some in French to cater for 
both types of visitor you want to attract.  

In this example, use the ‘Language’ drop down to select ‘English Canada’ for 
your English language pages and ‘French Canada’ for your French language 
pages.  

Google and other search engines will use this information to serve the 
appropriate content when a person performs a relevant search.  

If you only use one language in your website, use the File-> Edit Publishing 
Settings menu to globally set the ‘Language’ to the one you are using. 

The ‘Navigation Menu Display Name’ is the text that appears in your navigation 
menu if you use EverWeb's built in Navigation Menu Widget.  

The Navigation Menu Display Name is another elements to optimize for search 
engines as shown in the SEO For EverWeb Video Course. 

The Navigation Menu is discussed in more detail later in the User Manual and 
in EverWeb’s Video Tutorials which can be accessed from the Help-> Video 
Tutorials menu.  

You have the option of including each page of your site in the navigation menu. 
By default, each page is included in the navigation menu, If you do not want 
this, uncheck the ‘Include page in navigation menu’ option. 
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The ‘Web Page Title’ appears at the top of your page in the web browser. The 
Web Page Title is another element to optimize for search engines. The video 
tutorials, again, has extensive information making a good page title. Web page 
title’s should include a description of your page’s function but should not be 
more than about 160 characters long. 

The ‘Web Page Description’ allows you to add a description for each page. The 
description often appears when your page appears in a search engine results 
pages. The SEO For EverWeb video course has more details 
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Page Layout 
The Page Layout section (see 
Figure 13) is where you define the 
specifications of your page.  

First, choose from a Left Aligned 
page, a Centered page, or a 
Dynamic Width page.  

Specifying a value greater than 
zero in the ‘Top Margin’ field will 
create a space between your 
website and the highest point of 
the browser window.  

For example, if you add a shape to a page, and move it into the Header all the 
way to the top, you will see that there is a white space between the top of the 
page and where the page begins. This white space can be made something 
different, and we will get to that in just a moment.  

‘Content Width’ determines how wide your website will be. There is no set rule 
for how wide your website should be. However, you should consider that most 
users do not like to scroll horizontally and monitors maybe smaller than yours. 
A good value to use is 980 pixels, but that is not a hard limit. 

The ‘Content Height’ determines the minimum length of the body of the web 
page. This rarely needs to be changed as the height will automatically adjust 
based on where you place objects (such as text, shapes or images) on your 
page. For example, dragging an object down on the page will increase its 
height. You will not see the value increase in this field, your page height will still 
be as long as you make it by way of the objects on the page. 
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Figure 13: The Page Layout section on the Page Settings tab.
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The ‘Header Height’ determines how high the Header will be. As with 'Content 
Height’, ‘Header Height’ also adjusts automatically based on what is in the 
Header. If you want the Header to be smaller decrease the value. 

Finally, the ‘Footer Height’ determines the height of the Footer. As with the 
Header and Content Heights, the Footer adjusts automatically based on where 
objects are placed within it. Decrease the value if you want your Footer Height 
to be smaller. 
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Page Background & Browser Background 
The Page Background appears behind your page content (see Figure 14). There 
are four options: 

• ‘None’ leaves the background as white 

• ‘Color Fill’ allows you to set the background as a solid color 

• ‘Gradient Fill’ allows you to use two colors that transition smoothly 

• ‘Image Fill’ allow you to place an image as the background. 

As mentioned earlier, selecting None will set the page background to be solid 
white. Color Fill allows you to click on the color button which will prompt the 
color window to appear. You can make the background any color you want it to 
be. 

 

Gradient Fill allows you to 
choose two different colors and 
have them blend together.  Each 
color can be chosen by clicking 
on the color button for each 
respective color. Once you have 
your two colors selected, you can 
modify the way you want the 
gradient to appear. For example, 
you can flip the order of two 
colors by clicking on the arrows.  

You can notice the page 
background changing when 
doing this. You can also choose 
the direction of the gradient. 
Toggling between the horizontal 
and vertical arrows will change 
the direction of the gradient 
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Figure 14: The Page and Browser Background section on the 
Page Settings tab.
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from either horizontal or vertical. Alternatively, you can manually change the 
direction by adjusting the angle with the toggle, or by clicking on the up and 
down arrows. 

If you want to have an image for your background, you will need to choose the 
image from your list of Assets, or from your hard drive by selecting Choose to 
open the Finder window. Once your image has been set as the page 
background, you can either have it set to Scale to Fit, Scale to Fill, Stretch, 
Original Size, or Tile. The option you choose will depend on the image you 
want as your page background. 

If you want, you can add a background shadow to your page by clicking the 
Shadow option. You can select the color for your shadow, and how big you 
want the shadow to be. The shadow option works with any type of page 
background. 

You can also add a browser background to your site. The browser background 
is the background styling behind your content area. For the browser 
background, there are two options. You can choose Color Fill which will allow 
you to choose a solid color for your browser background, similar to the page 
background. If you want this left as white, then you do not need to select 
anything. 

You can also choose to Image Fill the browser background. Again, you can 
select the image from your Assets list or choose to locate the image on your 
hard drive by pressing the ‘Choose’ button. When your browser background 
image has been set, you can leave it as Tiled or change it to Original Size. 
Again, the option you choose will be dependent on the image you have 
selected to use for your browser background.  
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Mobile Settings 
EverWeb allows you to create a mobile version of your website. 

If you are using one of EverWeb's 
built in Themes, just click on the 
‘Add Page’ button, and select the 
theme you want to use, and then 
select the ‘Mobile’ page of that 
theme. 

If you want, you can also create your own mobile pages. Just make sure to set 
your page's Content Width is set to be mobile appropriate. EverWeb’s mobile 
theme pages are set to a Content Width of 480 pixels. This fits nicely with iOS 
and most mobile devices. 

When your mobile page is ready, you must now assign the Mobile page to one 
of your regular pages. When you do this, EverWeb will automatically show the 
Mobile page when a visitor comes from a Mobile device. 

To set up your mobile redirect, select the page on your Web Page List that 
should redirect to a mobile page. Usually this will be your home, or default 
page. Then, on the Page Settings tab in the Inspector window, once again 
locate the Mobile Settings section (see Figure 15) and from the Mobile Page 
drop down menu, select ‘One of My Pages’, and then select the mobile page 
from the ‘Page’ drop down menu.  

If you have multiple pages for your mobile site, just repeat these steps on those 
pages.  

When you publish your website, the mobile redirect will be enabled and you 
will be able to test this by visiting your website on your mobile device. 
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Header/Footer Code 
The ‘Header/Footer Code’ sections allow you to inject programming code, or 
script, in to your web page. The Header/Footer Code section is, therefore, of use 
to advanced EverWeb users. Typically you will not need to enter anything in to 
this section. 

Just like the rest of the settings on the Page Settings tab, any code or script 
entered into either fields will be applied to the respective page only, and not 
the entire site.  

Any codes placed in the Header Code section will be placed within the <head> 
tag in your HTML code.  

Any code placed in the Footer Code section will be placed right before the 
closing </body> tag. 
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Password Protection 
EverWeb lets you easily password protect the whole, or certain parts, of your 
website. 

For example, you could create a members only section on your website, or 
restrict access to certain individuals. 

Note: Password protection will only work on EverWeb’s Hosting platform. In addition, it can 
only be applied to Directories added to the Web Page list. 

To use Password Protection, use the ‘Add Directory’ button in the Toolbar. 

Click on the ‘Add’ button in the ‘Password Protection’ section. 

You can have unlimited passwords but all usernames must be unique. Also, you 
cannot use single quotes in the username or password field. 
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Redirects 
Redirects are a powerful but advanced feature. Say you have an existing 
website, such as an iWeb site that has been around for a while. You may have 
high search engine rankings for this site or you may have provided these links 
to other people. 

EverWeb lets you automatically redirect individual pages from your old site to 
your new site using a special type of redirect called a 301 redirect. These 
redirects have the benefit of maintaining your search engine rankings. 

To use this feature, enter the full URL of your old page. You can find the old URL 
by simply visiting your old site in your browser and copying and pasting the 
URL in the Path bar at the top of your browser window into this field. 

Remember, This feature is for individual pages. Each page on your old website 
should redirect to a unique page on your new EverWeb website. DO NOT just 
enter your main website’s URL for each page. Every redirect page in EverWeb 
should have a unique URL. 
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Shape Options 
All About Shapes & Images 
You can add a shape to your website by clicking on the Shapes 
button in the Toolbar, then selecting the shape you want to use 
(Figure 16).  

Shapes can be made larger or smaller, and moved around the 
Editor Window to your desired location. 

Use the Shapes tab in the Inspector Window to modify a shape 
(Figure 17). 

You can change the type of shape you are using by clicking in 
the drop down menu and selecting the shape you want.  

For each shape, there are three settings that you can make Fill 
modifications for: 

• Normal: How the shape will appear when no mouse 
cursor is over it 

• Mouse Over: How the shape will appear when the mouse cursor is 
hovering over it 

• Mouse Down: How the shape will appear when the shape has been 
clicked on. 

Tip: Any shape can have text on top of it. Just double click on the shape and begin typing. 
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Figure 16: Shapes
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For the shapes appearance, you have five options to choose from: 

• None: Makes the shape transparent - 
essentially what a text box is. 

• Color Fill: Allows your shape to have a 
color. Click on the color icon to 
change the color of the shape.  

• Gradient Fill: Allows the shape to be 
two different colors that transition 
smoothly. 

• Advanced Gradient Fill: Similar to the 
Gradient Fill but allows you to include 
more than two colors. 

• Image Fill: Lets you select an image 
to fill the shape with. 
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Figure 17: Shape Options
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Stroke Options 

You can apply the following Stroke options to your shape: 

None 

No options are applied to the shape. 

Line 

Shapes can have a line stroke surrounding them. Select ‘Line’ from the Stroke 
drop down menu (see Figure 18).  

You can choose between a solid line, a dashed line and a dotted line.  

To set the color of the line using the color swatch. 

To set the thickness of the line by entering a number in the box, or by using the 
up/down arrows. 

Picture Frame: 

To add a picture frame to your shape: 

1.Select ‘Picture Frame’ from the Stroke drop 
down menu. 

2.Click on the picture frame thumbnail and 
select the frame you want to use (see Figure 
18).  

3.Modify the thickness of the picture frame 
by adjusting the slider. 
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Figure 18: Picture frames can be added to any 
image, shape, or text box.
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Shadow Options 

To add a Shadow to your shape click on the Shadow option (see Figure 17). 

Choose the shadow color you want by clicking on the color swatch 

The direction of the shadow can be altered by rotating the wheel icon or by 
entering a number from zero to 360 degrees in the box to the right of the 
wheel icon. 

Use Offset to set how far the shadow is away from the shape 

Use Blur to alter the sharpness of the object 

The Opacity is used to alter the opaqueness of the shape i.e. how see through 
or solid the shadow appears. 

Reflection Options 

You can also add a reflection to your shape, and specify how large you would 
like the reflection to be using the slider. 

Opacity Options 

To adjust the opacity of a shape, use the slider or the up/down arrows or enter  
the value in the box. 
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Animation Options 

You can animate objects to produce some amazing effects on your web page. 

1. Start by select the object you want to animate. Select multiple objects 
if you want to apply the same effect to many objects at the same time. 

2. In the Shape Options tab, tick the checkbox next to the word 
‘Animation’. The animation options are now displayed. 

3. A number of different animation styles are available in the first drop 
down list. Click on the animation effect you want to use. If you select 
‘Other’, a second list of animation styles will become available in the 
second drop down menu, 

4. Once you have selected an animation effect from the first drop down 
menu, use the second drop down menu for further styling options e.g. 
if you selected the ‘Flip’ animation effect from the first drop down 
menu, you have the styling options of ‘In Place’, ‘Horizontal’ or ‘Vertical’ 
available from the second drop down menu. 

5. If you selected ‘Other’ from the first drop down menu, you will see 
more animation effects listed in the second drop down list. These 
animation effects do not have any additional styling options. 

6. When you select your animation effect and styling options, you can see 
a preview of the effect in the preview window at the bottom of the 
‘Animation’ settings. 

7. Once you have chosen your animation effect use: 

• Duration: To specify how long the effect will last for (in seconds and 
milliseconds;) 

• Delay: To delay the start of the animation effect (in seconds and 
milliseconds) 

• Repeat: To replay the animation effect the number of times 
specified. 

8. Use the Preview button in the Toolbar to see the animation effect 
working on your page before publishing your website. 
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Metrics 
Positioning Objects 
 

When building your website, it is important to position text, shapes and images 
exactly where you want them to be. There are different ways in which you can 
position these ‘objects’. For example, to center an object on the page, first 
select the object. Next, go to the Arrange > Align Objects menu option and 
then select Center. The object is centered. 

Likewise, you can do the same if you want the object to be left aligned, or right 
aligned. You can also specify if you want the object to be placed at the top of 
the page, the bottom of the page, or directly in the middle of the page (see 
Figure 19.) 

Let's say you want to place the object in a specific location according to X and Y 
coordinates.  

Tip: To move objects between sections, hold the command key as you drag them to another 
section. This will places them in the section you drop them into. 
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Figure 19: Object Alignment
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Click on the Metrics Tab in the Inspector Window, and modify the X and Y 
values in the Position section (see Figure 20).  

 

This will move the objects to the specified coordinates. You will see that you 
can also click on the up and down arrows which will move the object as you 
are changing the values.  

This method can be especially helpful when you have multiple objects that you 
want lined up. Simply match the Y values for each object if you want them to 
be lined up horizontally, or the X values for each object if you want them lined 
up vertically. 
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Figure 20: The position of objects can be changed 
by altering their x and y coordinates. 
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Allow Free Dragging 
You’ll notice when dragging objects around the EverWeb design canvas that 
you may be prevented from dragging the objects out of the Header, main body 
area or Footer.  

These three sections help you organize your web page design so that anything 
added in the Header section can actually move the content in the main body 
area and the Footer area down so that you don’t always have to adjust your 
design every time you want to change your header. 

The same applies to the main body area, where objects moved downwards 
here will adjust the top position of the objects in the footer. 

The ‘Allow free dragging' option tells a shape to ignore these boundaries and 
lets you drag it anywhere on the design canvas. The position of a ‘free dragging’ 
object does not affect any of the objects in any other section. 
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Fixed Positioned Objects 
EverWeb lets you have fixed positioned elements which means that as you 
scroll your website, the position of the object is always the same. This lets you 
add features like a navigation bar that is always displayed at the top of the 
browser window, even as the page is scrolled. 

Under the Metrics tab you’ll see the ‘Fixed position’ checkbox and the ‘Relative 
to browser left’ option underneath it. 

The ‘Fixed position’ option will make sure the object is always displayed exactly 
where you placed it on the design canvas as your page is scrolled vertically or 
horizontally. However, for a ‘Centered Aligned’ page, the default in EverWeb 
where your page content is always centered, the object will be anchored to the 
left margin of the page. This means the object’s left position will move as you 
resize your browser window. That lets you have the effect of a centered, fixed 
positioned object. 

By selecting the ‘Relative to browser left’ option, the object won’t adjust its left 
position as you resize your browser. Instead, it stays in the exact same position, 
no matter if you scroll or resize your browser. 

Remember the, ‘Relative to browser left’ option is only relevant when using the 
‘Centered Aligned’ page under Inspector->Page Settings->Page Layout section. 

Fixed position objects are great for navigation bars that should always appear 
for the user, even if they scroll their browser window. They are also great for 
including social media sharing buttons that you always want visible to your 
visitors. 
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Full Width Objects 
If you want to have an object that dynamically resizes its width as you resize 
the browser window, full width objects will let you do this. 

Under Inspector->Metrics you will see the ‘Full width’ option which does just 
that. When selecting, objects expand with the size of your browser. 

Remember that not all objects can be full width. For example, the image 
gallery cannot yet be full width but the Image Slider can be. For objects that 
cannot be full width this setting will have no effect on them. 

A full width navigation bar, or background object is a great example of when to 
use full width objects. They expand with the browser window to create a new 
affect for your visitors. 
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Distributing Objects 
 

Let's say you have multiple objects beside one another and you want to space 
them evenly. Select all the objects either by using your mouse, or by selecting 
each object while holding down the Command key on your keyboard. Then go 
to Arrange > Distribute Objects > Horizontally (see Figure 21). 

If the objects were placed vertically, repeat the above steps but but select 
‘Vertically’ instead. 
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Figure 21: Multiple objects can be distributed evenly either horizontally or vertically.
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Text and Text Options 
 

To add text to your website, simply click on the Text Box 
button, which is located in the Toolbar. A text box will appear 
on the editor, and you can edit it by double clicking inside the 
text box. Alternatively, if you have text on the site already, 
which might be there from a template, you can also double 
click inside the box to edit the text. 

 

There are two ways to edit your text. If you want to edit some of 
the text in the text box, highlight the text that you want to edit. 
If you want to edit all of the text in the text box, just select the 
text box on its own. If you want to change the font of your text 
click on the Fonts button, and then select the font you want to 
use. You, can also change the font size by adjusting the size 
using the scroll, or by typing in the font size.  

You can also change the color of the text by clicking on the text color icon 
which will bring up the Colors window. 

 

You can also change the text color by using the Colors shortcut located on the 
Toolbar. You can also click on the Text tab in the Inspector window, and change 
the color by clicking on the color icon which will also bring up the Colors 
window (see Figure 22). 
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You can also align the text left, center or to the right. You can align the text to 
be at the top of the text box, the middle of the text box, or at the bottom of the 
text box. 

If you want your text to have a colored background, you can select the 
Background Fill option, and then select the color image to change the color of 
the background.  

You can alter the space between each character by adjusting the character 
spacing. To alter line spacing adjust the line height of the text. You can also set 
the before and after paragraph spacing. For example, if you want there to be a 
larger gap between two paragraphs, you can either click after the paragraph 
and then increase the After Paragraph value, or you can click before the 
paragraph and then increase the Before Paragraph value. 

You can also modify the Inset Margin value for the text box, so that you can 
control where in the text box your text will be placed. The Inset Margin will 
apply padding around your text and the enclosing text box. 
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Modifying Fonts & Styles 
EverWeb makes it easy to work with different fonts and styles. To change the 
font, size, and styling of text you can use the ‘Fonts’ button in the Toolbar at the 
top of the main window. 

Important 
Working with fonts online can get tricky because not all users will have the font you want to 
use installed on their computer. When someone visits your website on their computer and they 
do not have the font you used installed, their web browser will substitute the font for an 
alternative, closely matching font. 

This can cause formatting issues for some users, especially if they are using a 
mobile device or an operating system that is different than yours. 

The font issue is further complicated due to the fact that fonts can have various 
licensing terms that restrict you from using them on your website without 
purchasing the appropriate license or checking with the creator of the font. 
Even if you use your font on your computer, you may not be licensed to use it 
on your website. 

There are four ways around the problem with fonts that each have benefits and 
drawbacks; 

1. Use only web safe fonts 

2. Use Google Fonts 

3. Convert your text to an image 

4. Use a custom font 

The best and most recommended solutions include; using the Web Safe fonts 
from the Fonts Panel or using Google Fonts. EverWeb makes working with 
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Google Fonts very easy and it is explained in more detail in the next section of 
this manual. 

The other solution is to use the option labelled ‘Export Text as Image’ under 
Inspector->Text Settings. For this to work select the Textbox you want to convert 
to an image and check the ‘Export Text as Image’ option in the Inspector. 

You must keep in mind that this option will prevent user’s from being able to 
copy and paste the text and will prevent search engines from being able to 
‘read’ the text that has been converted to an image. It is not recommended for 
text other then logos or critical text that needs to be displayed exactly the 
same in all browsers and all devices. 

The fourth option can get technical and also requires that you obtain the 
proper license for the font you want to use. You can actually include the font 
file in your website by following this third party tutorial on how to include 
custom fonts on your EverWeb website. 

Remember, custom fonts, even if they are included on your computer for your 
use, may not be allowed to be used on your website. Every font has different 
licensing restrictions so check with the creator of the Font if you are allowed to 
use your intended font on your website. You can usually find the creator of the 
font by Googling the font name in your web browser. 
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Using Google Fonts With EverWeb 
Google Fonts are a free and great way to include custom fonts on your website. 
EverWeb makes it really easy to work with Google Fonts. 

Google provides over 600 free fonts that you can use on your website and that 
are guaranteed to work across virtually all browsers and devices. It is your best 
option to provide unique fonts for your visitors. 

EverWeb makes it very easy to use Google Fonts on your website. All you have 
to do is follow these steps; 

1. Visit the Google Fonts web site and find the font you want to use 

2. Once you have found the font (or fonts) you want to use, click the ‘Add 
to Collection’ button next to each font 

3. Once you have collected all the fonts you want to use, click the down 
arrow in the top right corner to download the fonts to your computer 

4. The fonts will be downloaded to your computer and you can simply 
double click them to install them. You may need to close and re-open 
the Fonts panel in EverWeb (or even quit and relaunch EverWeb in 
some cases) to see them in the Fonts Panel 

5. Then just use the fonts as you normally would and EverWeb takes care 
of the rest when you publish your website 

A detailed tutorial on using Google Fonts in EverWeb can be found here. This is 
a third party tutorial with detailed instructions and screenshots on using 
Google Fonts on your EverWeb website. 
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Hyperlinking Objects 
 

Linking any object in EverWeb is very easy to do. Simply select the object, and 
click on the Hyperlink tab in the Inspector window (Figure 23).  

Check the box to ‘Enable as Hyperlink’. You will then be able to select where 
you want to link the object to. 
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You can choose to link one of your website pages by selecting ‘One of My 
Pages’, and then choosing the page that you want to link to from the second 
drop down menu. 

You can choose to link to an external page by typing in the URL you would like 
to link to. If you want the link to open in a new window when the user clicks on 
the link, select the option to Open in New Window. 

You can choose to link to a file, which you can choose from on your hard drive. 

You can also choose to link to an email message by entering the destination 
email address and subject. When a user clicks on the link, their default email 
client will open with the email address and subject already plugged in.  

If you link text, you can edit the Hyperlink Formatting for that text. You can 
change the color for how the text will appear normally, when the user hovers 
their cursor over the link, when the user has already visited the link, and how 
the link appears if it has been disabled. Each of these options can be 
underlined by clicking on the underlined ‘U’. 
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Using Scroll Position 
 

EverWeb’s Scroll Position feature lets you easily set up ‘anchors’ on your pages 
that can be hyperlinked to a piece of text, shape or any other object that can be 
hyperlinked to. In this way you can hyperlink to any position, on any page, 
within your website! 

For example, you may want a button at the top of the page that when clicked 
upon takes the visitor to a specific paragraph further down the page, instead of 
having the visitor manually scroll down to the paragraph (see Figure 24). 
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1. Create a button by adding a rectangle shape from the Shapes button 
in the Toolbar and position it at the top of the page. Click inside the 
button and add the button text you want. Use the Text Inspector 
Alignment options to position the text in the center of the button. 

2. Once you have set up your button, click on the Scroll Position button in 
the Toolbar, or use the Insert -> Scroll Position menu option. 

3. A light blue horizontal line appears across the width of the page near 
the the top of the body section of the page. The blue line acts as an 
‘anchor’. 

4. Click and drag the blue line ‘anchor’ to where you want it on the page 
e.g. the top of a paragraph further down the page. Notice that the line 
does not have any selection handles and is dark blue when not 
selected. 

5. Once you have placed the Scroll Position anchor, you will want to link it 
the button you added earlier. Click on the text in the button to select it. 

6. Go to the Hyperlinks Inspector and tick the checkbox ‘Enable 
Hyperlink’. 

7. Make the ‘Link To’ option ‘One of My Pages’. In the ‘Page’ section select 
the current page as this is where your Scroll Position anchor is located. 

8. The ‘Position’ field shows ‘Top of Page’. Click in the drop down and you 
will see another option starting with ‘scrollposition’ followed by a ‘-‘ and 
a number e.g. ‘scrollposition-857’ means that the scroll position anchor 
you added is 857 pixels down from the top of the page. See Figure 37. 

9. Select the scroll position. The button and the scroll position are now 
linked. 

10. From the Toolbar select Preview to test that the button and scroll 
position are set up correctly before publishing. Click on the hyperlinked 
button. You should automatically scroll down to the paragraph where 
you set the scroll position at. 
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Nofollow Link 
The Additional Settings section has a ‘Nofollow link’ option. When you link to 
page you are implicitly telling your visitors. or search engines, that this is a 
recommended page by you. Sometimes this may not always be the case e.g. 
linking to a competitor website or page. 

For your actual visitors, the context of your link could indicate that this isn’t 
actually something you recommend. However, search engines will still believe 
you are vouching for this linked page.  

By selecting ‘Nofollow link’ you are essentially telling search engines that you 
don't actually vouch for this page and that you don’t want to pass your 
website’s reputation to this page.  

This is important because if you link to a page with a bad reputation according 
to search engines, it can negatively affect your page’s reputation and in turn 
lower your search engine rankings. 

Select this option when linking to a page you don’t particularly trust or 
recommend. 
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Linking to PDF files or other Files for Download 
You can easily link to any file, including PDF files, for website visitors to 
download from the Hyperlinks tab. 

From the ‘Link To:’ drop down menu select ‘A File’. Then from the ‘Choose…’ 
button select the the file from your computer that you would like user’s to 
download. This can be anything including; PDF files, word documents, images 
etc. 

The linked file will appear in the ‘External Files’ section of the ‘Assets List’. The 
file is copied into your Project’s folder and then to your server when publishing 
your website.  

Linked files are not downloaded from your actual computer, they are 
downloaded from the copy that EverWeb has published to your website. 

www.everwebapp.com   of  72 141

http://www.everwebapp.com


EverWeb User Manual Images & The Assets List

Images & The Assets List 

If you want to add images to your website in EverWeb, there are many ways to 
do this. For example, you can drag the image from your desktop onto the 
editor. You can also drag the image from the Finder window onto the editor. 
You can also go to ‘Insert’ in the menu bar and select ‘Choose’ and then choose 
the image you want to add.  

You can also add an image by adding a text box or shape: 

1. Add text box or shape to your page (any shape will do). 

2. Click on the Shape tabs in the inspector window 

3. Select Image Fill from the drop down menu.  

4. Click the Choose drop down menu and select Choose which will open 
the Finder window, and then select the image that you want.  
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The same method can be applied for adding an image to the Page and 
Browser Backgrounds. 

Any image added to the site will appear in the Assets section (Figure 25). You 
can add any image to this list by just dragging the image from your hard drive 
and dropping it in the Assets List. 

You can then add the image to any page on your site by dragging it from the 
Assets list and dropping it on the editor.  

You can preview the image by clicking on the eye icon to the right of the image 
in the assets list.  

The great thing about the Assets List is if you want to use the same image 
multiple times throughout your site, you do not need to keep adding the 
image to the site using the methods outlined earlier. When the image is added 
once, it remains in the assets list and you can access it no matter what page on 
your site you are currently on.  

Tip: If a shape is using an Image asset, when you select that shape in EverWeb’s designer it will 
also be selected in the Assets List. 
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Images & The Media Browser 
There is one other important, and powerful, way of adding 
images to your site. If you click on the ‘Media’ button, 
EverWeb's media browser will appear (Figure 26). 

 

You can now add images to your site from media 
locations on your hard drive such as iPhoto, and 
your Pictures folder. If you want, you can drag and 
drop additional folders onto the media browser so 
that you can access images from any folder on your 
hard drive.  

Whenever you want to add an image from the 
media browser to your EverWeb site, simply drag 
and drop the image either on the editor or in the 
assets section.  
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Stock Photos 
EverWeb allows you to easily access over half a million free to use stock photos 
that can be included in your website. 

To add a Stock Photo to your page: 

1. Go to  the Window-> Stock Photos… menu option.  

2. The Image Search window will open with a search bar at the top. 

3. Enter the word(s) that you are searching for e.g. ‘Cat’ and press Enter to 
perform the search.  

4. Images that match your search criteria will be displayed below the 
search bar. If no results are found, the Image Search window displays 
the text ‘No Results Found’. 

5. Drag and drop the image that you want to use onto the Editor Window.  

6. To add a Stock Photo in a blog post, first make sure the blog post you 
want is selected, then drag and drop the image from the Image Search 
box onto the Blog Post Editor Window or Blog Post Preview Window. 

7. To add a Stock Photo to the Assets List, first select the Assets tab, then 
drag and drop the Image you want from the Image Search box into the 
Assets List. The saved image can then be used later. 

8. Images in the Assets List are named after the search criteria. 

You can keep the Stock Photos search window open whilst working on your 
website. If you want to bring the Stock Photos search window to the front, just 
use the Window-> Image Search option. 

When you quit EverWeb, the Image Search window also closes. When you 
enter EverWeb the next time, you will need to reopen the Stock Photos Image 
Search window again to use it. 
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Widgets 

EverWeb includes a number of built in 
‘Widgets’ which are like mini apps that 
allow you to easily add extra features you 
may want to your website (see Figure 27). 
For example, use the Navigation Menu 
widget to create a simple, dropdown or 
responsive menu systems for your website. 
You can use the PayPal widget for E-
Commerce, the Image Slider and Image 
Gallery widgets to display images in a 
number of different ways and so on. 

1. Adding a widget to your web page 
is easy: 

2. Select the page that you want to 
add the widget to.  

3. Next select the Widgets tab in the 
Inspector Window on the right 
hand side. 

4. Find the widget you want to use 
and drag and drop it on to the 
Editor Window. 

5. Size and position the widget as 
required. 

6. Use the Widget Settings in the 
Inspector Window to customize the 
widget, or setup widget specific 
defaults, as you want. 

You’ve already met many of EverWeb’s built in widgets earlier in the manual. 
The following pages list all of the widgets built in to EverWeb, what they are 
and how to use them. 
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Audio Widget 

The Audio widget supports the HTML5 Audio Player so you can add MP3 files to 
your web page. You can set the default playback volume, and there are also 
options for looping, autoplay on page load and muting the audio. 

Contact Form Widget 

To add a contact form to your website, drag and drop the Contact Form widget 
onto the Editor. On the Widget Settings tab, it is very important to enter your 
email address in the Email Address field. This is the email address that will 
receive any of the messages submitted using this contact form. You can edit 
the fields on the Contact Form if you want to add different fields other than the 
default fields on your form. For example, if you wanted users to submit their full 
names, you could change the Name field from “Name:” to “Full Name:” This will 
display Full Name and users using your form will know to enter their full 
names. 

Contact Form Advanced Widget 

Contact Form Advanced lets you create highly customized forms. You can add 
drop down menus lists, tick box lists, radio buttons and more, to your form. The 
Widget lets you add extra fields e.g. you could create a ‘Special Greetings’ field 
pre-fill with some default text such as ‘Add your special greeting here!’ to help 
your visitors complete the form successfully and easily. Contact Form Advanced 
is perfect for sales orders, customer surveys or any time when you need a 
flexible, highly customisable form solution. 

FaceBook Like Widget 

If you have a Facebook page, you can place a Facebook Like button on your 
website. Just drag and drop the Facebook Like widget onto the Editor. On the 
Widget Settings tab, enter your Facebook Page URL. 
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FaceBook Page Timeline Widget 

If you have a Facebook page, you can display it on your web page using this 
widget. Drag and drop the widget onto the Editor and enter your Facebook 
Page web address. Use the Widget Settings tab to customize the look of the 
widget. 

Google Maps Widget 

To add a map to your website, drag and drop the Google Maps widget onto the 
editor. On the Widget Settings tab, enter the address for the location you want 
the map to display. When you are done, click the Apply button. You can 
increase, or decrease the size of the map to suit your needs. 

Google+ Widget 

To add a Google Plus button to your website, drag and drop the Google Plus 
widget onto the editor. On the Widget Settings tab, type in or paste the URL for 
the page that you want the Google Plus button to be associated with. 

Heading Tags Widget 

Easily add HTML Heading Tags to your EverWeb pages using the Heading Tags 
Widget. You can style the Heading Tag to match your web page by just using 
the Fonts Panel and the Color Picker. 
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HTML Snippet Widget 

The HTML Snippet is the most powerful widget as it allows users to add almost 
anything to their website. Anytime you want to embed, or add an item to your 
website, if you are given an HTML script for that item, you will paste it in the 
HTML Snippet widget. 

Tip: The HTML Snippet widget lets you add any type of code to your website which makes it 
both powerful and having the potential to cause publishing problems if your enter incorrect 
HTML Code. Make sure you know what the code is doing when using the HTML Widget 

Image Gallery Widget 

Instantly create image galleries to show off your photography, art, family or 
more. EverWeb automatically creates professional image galleries for your 
website with the Image Gallery widget. 

Image Slider Widget 

The Image Slider widget creates a slideshow of images that can be set to 
transition from one image to the next. Drag the image slider onto your 
webpage and then add images using the ‘Choose…' button. 

Live Photo Widget 

Add Live Photos from your iPhone to your website. From the Photos app select 
the Live Photo you want, then go to File-> Export Unmodified Original Photo. 
Add the resulting .JPG and .MOV files to the Live Photo widget!  
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Navigation Menu Widget 

EverWeb’s built-in navigation menu makes it easy for users to have a navigation 
menu with links to some or all of the pages on the website. Simply drag and 
drop the Navigation Menu widget onto the editor, and a menu with links to all 
pages on your site will appear. 

You can modify the settings of your navigation menu on the ‘Widget Settings’ 
tab in the Inspector. On this tab, you will be able to change the navigation 
menu’s alignment, padding, spacing, and minimum width. You can also 
change background color and the mouse over color for the submenu. Please 
note that this feature is only applicable to those who are utilizing EverWeb’s 
drop down menus. 

If you want to change the font type and font size of the text, you can do so by 
clicking on the Fonts button in the Toolbar and making your changes. 

If you would like to change the text color, including the Rollover and Visited 
colors, you can do so on the Hyperlinks tab. You will be able to do this under 
the Hyperlink Formatting section, by clicking on the color icon next to the 
format option and selecting the color you would like. You can also select if you 
would like the links to be underlined. 

Tip: If you do not want one or more of your pages included in the navigation menu, make sure 
to disable the ‘Include in navigation menu’ option while on the page. This option is found on 
the Inspector area, on the Page Settings tab, and under the Page Details section. 

PayPal e-Commerce Widget 

The Paypal e-commerce widget lets you add either Paypal Buy Now buttons or 
a fully featured Shopping Cart. You can even add a ‘Donate’ button! 
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Pinterest Pin It Widget 

Use this widget to add a Pin It button to your page. To pin something on your 
page, click the Pin It button and then select the image you want. 

RSS Feed Widget 

The RSS Feed widget allows you to place a third-party website’s RSS feed on 
your website. This allows you to provide your website visitors with updated 
content, without having to do anything.  

To use the RSS Feed widget, simply drag and drop the widget onto the editor. 
On the Widget Settings tab, paste or type in the URL for the feed you want 
displayed on your website. 

You can adjust the widget on your site so that it is bigger, smaller, wider, or 
more narrow. You can also play around with the rest of the settings on the 
Widget Settings tab until you are satisfied with the way the RSS feed is 
displayed on your website. 

Twitter Follow Me Widget 

This widget allows you to add a Twitter Follow Me button to your page. Simply 
drag and drop the widget on the editor, and on the Widget Settings tab, enter 
your Twitter handle.  
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Video Widget 

If you want to add in MP4 Video, WebM or OGG video content to your website, 
this is the widget you need! 

Vimeo Widget 

The Vimeo Video widget lets you easily embed Vimeo Video content to your 
website. 

YouTube Video 

To embed a YouTube video on your website, you can drag and drop the 
YouTube Video widget onto the editor. On the Widget Settings tab, type in or 
paste the link for the YouTube video you want to embed. When you are 
finished, clicked the Apply button. You can modify the size of the video to suit 
your needs. 
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Blogging 

EverWeb lets you easily create your own online journal with its powerful, easy to 
use, blogging tool (see Figure 28). Your journal, known as a ‘blog’, can contain 
one or more articles, known as ‘posts’. Posts are great if you want to write 
longer, in depth articles that you want to keep separate from your regular web 
pages. Posts can also be used for short articles such as news items or 
announcements. Blog posts have a ‘free format’ style which gives you great 
flexibility in designing and writing your journal articles. 

You can format your blog posts in a number of different ways to suit your 
website style. Blog posts are listed in an blog index page which show your 
latest posts. Older posts can be accessed from an archive page. 
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Blogging Basics 
Creating a Blog 

 

To create a new blog, click the ‘Add Page’ button in the Toolbar. 
In the Template Chooser, select the ‘Blank’ template theme 
from the left hand column. Next highlight the ‘Blog’ page from 
the template pages on the right hand side then click the 
‘Select’ button. 

 

Your blog will be created in the Web Page List 
on the left hand side of the EverWeb User 
Interface. The blog has three parts to it (see 

Figure 29): 

• The Blog Main page is a directory page that acts as the blog’s ‘Index’ 
page. The Blog Main page lists the most recent blogs that have been 
created. The Blog Main page contains the ‘Posts’ page and the ‘Archive’ 
page. 

• The Posts page is where you create, edit, format and manage your blog 
posts and is the page you will probably use the most. 

• The Archive page is where older posts are listed. 
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Renaming a Blog 
If you want to rename your Blog, just double click on the word ‘blog’ in the 
Web Page List and overtype it with a new name. Press enter to finish. If you 
prefer, you can also use the File-> Rename menu option to rename the blog. 

 You can only change the name of the Blog Main page. The ‘posts’ page and 
‘archive’ page cannot be renamed. 

Deleting a Blog 
Deleting a blog works in the same way as deleting any page in EverWeb. Click 
on the Blog Main page in the Web Page List, then press the backspace key on 
your keyboard. 

Warning! Deleting the Blog Main page will delete the whole blog structure. The Blog Main 
Page, the archive page and ALL of the blog posts will be deleted! 

If you delete the Blog by accident, immediately press Cmd+Z to undelete it. 
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The Blog Main & Archive Pages 

The Blog Main and Archive pages use a ‘widget’ to display the list of blog posts 
that have been created. Blog posts are displayed in date order. The latest blog 
post is at the top of the list and the oldest at the bottom (See Figure 30). Each 
blog post displayed shows the blog post’s Title. You can optionally show the 
date the post was published under the Title and some of the blog post’s text if 
you want. 

The widget has a selection handle on each side so that you can change the 
width of the widget as you want. The height of the widget adjusts 
automatically as you change the Widget Settings, add new blog posts, or other 
formatting such as font size.  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Figure 30: The Blog Main page showing a list of blog posts. The whole list is contained in the Blog Main ‘widget’ 
that has a selection handle on each side. The Widget Settings are shown on the right.
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Customizing The Blog Main & Archive Pages 
 

The Blog Main and Archive pages can be customized in the same way as each 
other. For example, to customize the Blog Main page first click on the ‘blog’ 
page in the Web Page List. 

If you do not see the selection handles on the sides of the widget, click once 
inside the widget to display them. Next select the Widget Settings tab (see 
Figure 31) in the Inspector Window. You now have a number of different 
options available to customize the look of the widget e.g. you may want to 
display only the first 100 characters of your blog post’s text so you would 
change the Article Length setting from 150 to 100. If you want to include the 
date of the blog posts tick the ‘Show published date’ box and so on. 
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Figure 31: When you click on any item in the Blog Main Widget e.g. a title, all of the same type of item are 
highlighted so you can apply formatting to them all at the same time.
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You can change the text formatting options of the widget 
easily. First click on the Fonts button in the Toolbar. With the 
Fonts Panel on screen, double click on either a blog post 
Title, the blog post date (if you have it displayed) or the blog 
post text. All of the same items will be highlighted e.g. all of 
the Blog Post Titles (see Figure 31). Select the fonts you want 
to use for the selected item. 
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Formatting Blog Post Titles 
The blog posts titles are actually hyperlinks to the blog posts themselves.  

That’s why they’re displayed in the default hyperlink styling of blue, underlined 
text. To alter the hyperlink colors and underlining, first select the Titles as 
described above.  

Next go to the Hyperlinks tab in the Inspector Window. In the Hyperlinks tab 
you can set the color and underline for normal, hover and visited states.  

For more information please see the section on the Hyperlinks tab. To change 
the font styling of the Titles use the Fonts Panel as described above. 

Formatting Blog Post Dates & Content Summaries 
Just as you did with the blog post Titles, you can double click any post date or 
post summary to change the formatting.  

Double click the post date or the content summary and open the Font panel 
from the Toolbar. 
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The Blog Posts Window 

The Blog Posts window is the heart of your blogging experience in EverWeb. It 
has four sections (Figure 32): 

1. The Blog Posts List at the top lists all of the blog posts that you have 
created (see Figure 32 - Section A) 

2. The Blog Editor Window in the middle is where you add the blog post 
text. You can also add images, hyperlinks, lists and format your text (see 
Figure 32 - Section B). 

3. The Preview Window at the bottom is where you see the formatted 
blog post including the blog post title, as well as the date and 
comments section if you have included these (see Figure 32 - Section 
C). 
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Figure 32: EverWeb’s Blog Posts Window has three sections: The Blog Posts List, the Blog Editor window 
and the Blog Preview window.
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4. The Widgets Settings tab where you can change styling settings for 
individual blog posts or all your blog posts (see Figure 32 in the 
Inspector Window)  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The Blog Posts List 
The Blog Posts List is where all the blog posts you have created are listed and 
managed. 

Creating a Blog Post 
Once you have created a blog, click on the Posts page in the Web Page List. The 
first blog post has been automatically created for you. To add more posts, click 
the ‘New Post’ button and enter the blog post title. Press enter to finish 
creating the new post. 

Duplicating a Blog Post 
To duplicate a blog post, click on the blog post you want to duplicate, then 
right click on the highlighted blog post. Select ‘Duplicate’ from the menu.  

Deleting a Blog Post 
To delete a blog post, click on the post you want to remove in the Blog Posts 
List then click on the ‘Delete Post’ button. 

Renaming a Blog Post 
To rename a blog post, double click on the blog post’s name in the Blog Posts 
List and type over the name that’s there already. Press enter to finish. 
Alternatively, highlight the blog post and use the File->  Rename menu 
command if you prefer. 
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Changing the Blog Post Date and/or Time 
To change the date and/or time the post was created, double click on the blog 
post date in the ‘Date’ column and enter the new date and/or time. Click 
outside of the calendar window to finish. 

Changing the Blog Posts List Sort Order 
To sort the Blog Posts List in ascending or descending alphanumeric order, 
click on the words ‘Blog Posts’ to toggle the sort order. Click on‘Date’ to sort the 
blog posts from newest to oldest or oldest to newest. 

Resizing the Blog Posts List 
The Blog Posts List can be resized to display more or less blog posts. To do this, 
move your mouse pointer to the line between the last post and the row of 
buttons. The cursor will change to a splitter line. Click and drag up or down the 
splitter line up and down as required then release the mouse button when you 
are done. 
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Importing Blog Posts Into EverWeb 
EverWeb can easily import blog posts from other sources such as iWeb or 
Wordpress using the ‘Import’ button (see Figure 32 - Section A). 

You should already have created a blog within EverWeb so that you can then 
import your existing blog posts from iWeb or WordPress. 

Importing Blog Posts from iWeb 

1. Before importing your iWeb blog entries into EverWeb, first use iWeb to 
publish your iWeb website to a folder on your local hard disk. 

2. After publishing your iWeb website to a folder, click on the Import 
button in EverWeb’s Blog Posts List Window.  

3. Select ‘iWeb’ from the drop down menu and click on the ‘Import’ 
button.  

4. Navigate to where you published the iWeb website on your local hard 
disk and select ‘Open’.  

5. EverWeb will list the blogs that it has found e.g. ‘blog’. Select the entry 
you want from the list and select ‘Import’.  

6. Your iWeb blog entries will be processed and listed as blog posts in the 
Blog Posts List. 
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Importing Blog Posts from Wordpress 

1. Before importing your Wordpress blog posts into EverWeb, you will 
need to export your Wordpress blog. 

2. First login to WordPress and go to the Tools->Export menu.  

3. Click on ‘Posts’ and select the settings you want to use.  

4. Next, press Export.  

5. When the export is complete, you can import the file In EverWeb. 

6. From the Blog Posts List click the Import button. Select WordPress and 
choose the .xml file that you exported from WordPress.  

7. The file will be processed and your Wordpress blog posts listed in the 
Blog Posts List. 
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Importing Images in to your Blog Posts 

Images can be imported in to your blog posts. Simply drag and drop the image 
from its source location to either:  

1. The Blog Posts Editor window if you want the image to only appear on 
the currently selected blog post 

2. The Preview Window if you want the image to appear on all of your 
blog posts. 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The Blog Editor Window 

Editing a Blog Post 
The Blog Editor Window is where you enter the text of your blog. Once you 
have created a new blog post, select the placeholder text ‘This is a sample blog 
post’ and start typing. You can also paste in text that you have copied to the 
clipboard. 

At the top of the Editor Window is the Editing Toolbar where you can quickly 
apply text formatting to your blog post (see Figure 33). The Toolbar works in 
much the same way as in word processing applications.  

You can resize the Editor Window height by hovering the mouse on the border 
line between the Editor and Preview Windows. The mouse pointer will change 
to a splitter symbol. Click and drag the splitter up or down until you have the 
Editor Window the size you want it, then release the mouse button. 
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Figure 33: The Blog Editor Toolbar contains frequently used editing features for quick access.
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Formatting Text in the Blog Editor 
As well as the formatting options in the Blog Editor Toolbar, there are other 
ways to achieve the look that you want for your blog text.  

The Text Inspector can be used to change blog text character spacing, line 
height, spacing before and after a paragraph and even insert a margin in the 
blog post widget itself.  

To use these options, just highlight the text in the Blog Editor Window then 
click on the Text Inspector tab and use the options listed. 
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Hyperlinking Blog Posts 
Linking a blog post to a page in your website is easy to 
do. Simply select the object on the page you want to 
link the blog post to e.g. a piece of text.  

Click on the Hyperlinks tab in the Inspector window 
(see Figure 34). Check the box “Enable as Hyperlink”.  

To link a blog post select “One of My Pages” from the 
Link To options. Next choose the blog post you want 
to link to from the drop down menu in the “Pages” 
option.  

The link is all set up so when someone clicks on the 
linked text they will go to the blog post. 
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Figure 34 The Hyperlinks tab.
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Images in the Blog Editor Window 
Images can be drag and dropped directly in to the Blog Editor Window. Once 
you have dropped the image in from its source, or from the Assets List, click on 
the image to select it. The selected image has a blue border with square 
selection handles in each corner that you can drag to resize the image.  

A Blog Image Toolbar is displayed either above or below the selected image 
(see Figure 35). You can align the image to the left or right or not at all. You can 
also have the image display inline with the text or ‘breaking’ so that the text 
only displays above and below the image. There’s also an option to add 
Alternative Text to the image that is used by search engines to add keywords or 
context to your image that they can understand. 
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Figure 35: The Editor Window showing a selected image and the Image Editing Toolbar.
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If you have dropped the image on to the Blog Preview Window, the above 
options are not available. The next section tells you more about using images 
and objects in the Preview Window.  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The Blog Preview Window 

The Blog Preview Window is where you see 
how your blog post will look when published. It 
is similar to a Master Page as when you add, 
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Figure 36: You can add objects such as social media buttons to 
the Blog Preview Window so that they appear on all of your blog 

Figure 37: The Blog Posts Widgets 
Settings including the Comments 

Options section.
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edit or delete objects, or change any formatting, these changes are applied to 
all your blog posts e.g. if you add social media buttons in the Blog Preview 
Window of one of your posts, the buttons will appear in all posts (see Figure 
36). 

The text entered in the Blog Editor Window appears in the Blog Post Widget in 
the Preview Window as does the blog’s Title at the top. You can apply 
additional display and formatting options using the Blog Post Widget Settings. 
As such, what you see in the Blog Editor Window may appear differently in the 
Blog Preview Window due to the formatting that you may have applied. 

For example, the text may wrap at a different point if the blog widget is smaller 
than the blog entry field. 

Blog Post Widget Settings 
You can format all of your blog posts to have the same look using the Blog Post 
Widget Settings tab. For example, if you change the font of the Blog Post Title 
in the Header Options, the change will be applied to all of your blog posts. 

There are many different options to choose from such as including the date of 
the blog post and Navigation Links that make it easy for your visitors to move 
through your blog posts of return to the Index (Blog Main) page 

Formatting The Blog Post Preview Page 
The Blog Post Options change the formatting of the blog posts themselves. If 
you want to change other aspects of the Blog Preview Window, use the 
Inspector Window. For example if you want to change the background color of 
the blog posts, use the Page Settings tab and set the Page and Background 
color to how you want it. 
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Adding Objects in to the Preview Window 
You can add in other objects such as images and buttons in to the Preview 
Window. When you do this, the object will display in all of your posts. This is 
very useful if you want to add, for example, social media buttons, or a company 
logo, to your blog posts (See Figure 15). The Preview Window is in many ways 
similar to the way in which EverWeb’s Master Pages work (see the following 
section for more information). 

Tip: To add an object just to one blog post, add the object in to the Editor Window. 
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Navigation Links 
You can include navigation links at the bottom of your blog so that visitors can 
easily go the next or previous blog or back to the Index page. By default, 
EverWeb displays these navigation links. If you do not want them, use the Blog 
Posts Widget Settings and deselect the ‘include navigation links’ and/or 
‘include index page link’. 

The navigation links can be customised using the Navigation Links ‘Fonts’ 
button. To change the color of the links, use the Post Link Normal, Hover and 
Visited options as the navigation links are hyperlinks to other pages in your 
website. 
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Adding Commenting To Your Blog 
You can let your visitors discuss and leave their own comments about your blog 
posts by using a ‘Comment Engine’. EverWeb allows you to use either Disqus or 
Facebook’s comment engine. Both comment engines require that you set up 
an account beforehand. 

Choosing Your Comment Engine 
You can choose to use either Disqus and Facebook Comments (see Figure 37). 
Both offer similar features to each other although you may want to consider 
that… 

Disqus is better if you want real time conversations and an easy to use interface 
whilst 

Facebook Comments is better if you have a large number of website visitors 
using Facebook and for visitors who want their comments published in their 
Public Facebook profile. 
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Getting a User ID for Disqus or Facebook Comments 
Creating a User ID in either Disqus or Facebook Comments can seem 
complicated at first as each offers many different setup options. However, 
these options are not usually needed. All you need is the User ID itself to get 
started in EverWeb. 

The steps below will help guide you in setting up Disqus or Facebook 
Comments. As there are a number of different user situations, you may find 
that you need to complete only some of the steps shown, or you may need to 
complete more steps than are shown below. 
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Using Disqus as your Comment Engine 
 

1. First sign up for an account at the Disqus website if you don’t already 
have an account.  

2. You can use your Facebook, Twitter or Google accounts to sign up, or 
use your email address if you prefer. (See Figure 38A)  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Figure 38A: The Disqus Sign Up screen
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3. When you sign up, click on the‘Get Started’ button on the ‘#1 way to 
build your audience’ screen (See Figure 38B). 

4. Next you will see the‘Create a new site’ screen (See Figure 38C). The 
‘Site Owner’ will be the name you used as your sign up name. 

www.everwebapp.com   of  112 141

Figure 38B: Getting Started with Disqus 
Setup

Figure 38C: The Create a new site screen
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5. When you enter your ‘Website Name’ (highlighted in the red box in 
Figure 17C) you will see that Disqus automatically creates a ‘shortname’ 
which will be the User ID. 

6. Make a note of your ’Shortname’ as you will use this later in EverWeb! 

7. Complete the details and click on ‘Create Site’. Your Disqus ID will be 
created and you will now be offered a number of customization 
choices. 

8. Click on the button ‘Yes, I understand Disqus is both comments and 
native Apps’ on the next screen. 

9. You will next see a screen with options to install Disqus on different 
platforms (See Figure 38D).  

10. Click on the ‘Universal Code’ button at the bottom of the screen. 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Figure 38D: Choose the Universal Code option 
as your Platform
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11. Scroll to the bottom of the next screen and click the button. Continue 
to do this until you see the ‘Setup Complete’ screen (See Figure 38E). 

You have now finished the setup process and have a Shortname that can be 
used in EverWeb.  
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Figure 38E: The Setup Complete screen for Disqus
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Using Facebook as your Comment Engine 
To use Facebook as your comment engine: 

1. Sign up to Facebook at www.facebook.com if you do not have an 
account already. 

2. Once you have a Facebook account you will need a Facebook App ID. 
To do this you need to be a Facebook Developer (See Figure 39A) 

3. If you have not done so already, convert your Facebook account to a 
Facebook Developer account by selecting the ‘Docs’ menu.  
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Figure 39A: The Facebook Developers Home Page with the ‘My Apps’ button in the top 
right hand corner of the screen
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4. Click on ‘App Development’ in the ‘Product Docs’ or ‘Guides’ section, 
Next select ‘Creating an App ID’ from the ‘App Development’ list. 

5. Scroll down to ‘Developer Account’ and ‘click on ‘Create Developer 
Account’ (See Figure 39B). 

6. Once you have completed the registration you can add Facebook in to 
your app or website. 

www.everwebapp.com   of  116 141

Figure 39B: Select ‘Creating an App ID in the left column and then  ‘Create Developer 
Account’ in the right column.
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7. Facebook will ask you which application platform you are using. If you 
have already registered, use the ‘My Apps’ button and select ‘Add a 
New App’ from the menu. 

8. Click on ‘WWW” for your website (See Figure 39C).  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Figure 39C: The Add a New App screen. Select the ‘www’ option.
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9. In the ‘Quick Start for Website’ window, type in the name you want to 
call your app e.g. the name of your website and then click on ‘Create 
New Facebook App ID’. Remember to select a ‘Category’ as you cannot 
proceed if you don’t (See Figure 39D). 

10. Once the App has been created, you will see the ‘Setup Facebook SDK 
for JavaScript’ screen. Enter your website URL at the bottom of the 
screen and click ‘Next’. 

11. Scroll down until you see the section ‘Next Steps’. ’ 

12. Click on ‘Skip to Developer Dashboard’.  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Figure 39D: The Create new App ID Screen.
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13. At the top of the Dashboard is your App ID number which you can now 
use in EverWeb (See Figure 39E). 
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Figure 39E: The Facebook Developer Dashboard showing the App ID at the top of the 
screen
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Enabling Comments in EverWeb 
Now that you have your Disqus Shortname or Facebook App ID, go to the 
Comment Options section in the Widget Settings of your Blog Posts in 
EverWeb (see Figure 37 above). 

In the Comment Engine section, select either Disqus or Facebook then enter 
your Disqus Shortname or Facebook Comments App ID in the box below. 

Your comment section is now setup! The Blog Preview widget will update 
showing the comment engine is enabled at the bottom of the widget. 

When your website is published to the Internet, visitors to your blog posts can 
add their own comments. A visitor will need to login to Disqus (or sign up 
which can be done via the login section in the Disqus Comments) or Facebook 
Comments (using their Facebook login) to be able to comment. 
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Managing Comments on Your Blog 
You are responsible for monitoring the comments that are placed on your blog 
by your visitors. As a ‘moderator’ you can approve comments for public display 
on your blog, delete comments from your blog (e.g. if they are offensive) and 
tackle instances where your blog may be subject to spam. 

If you are using Disqus commenting please go to their moderator guidelines for 
more information. 

If you are using Facebook commenting please go to their online help resource 
center. 
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RSS Features and Blogging 

Your website visitors can always stay up to date with the blogs that you create 
in EverWeb through RSS.  

There are a couple of easy ways to use RSS to take advantage of your blogs. 

• The RSS Feed Widget 

• The RSS Subscribe button 

These features are described below. 
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The RSS Feed Widget 

You can use EverWeb’s RSS Feed Widget to show a blog summary on your web 
pages (See Figure 40) To do this, first go to the page where you want to add the 
blog summary. Next go to the Widgets Tab in the Inspector Window and drag 
and drop the RSS Feed Widget on to the page. 

In the Widget Settings you will now need to add in the location of your Feed 
URL. This location contains an rss.xml file that enables the blog entries to be 
displayed. the rss.xml file is located at 
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Figure 40: Use the RSS Feed Widget to add your latest blog posts to any page in your website
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 http://<your website address>/blog/rss.xml 

For example, Josh’s real estate business that we met earlier in the manual has 
created a blog for his website. His Feed URL may look like this 

    http://www.joshsrealestate.com/blog/rss.xml 

Once you have added the Feed URL choose which other options you want to 
use in the RSS Feed Widget Settings. then publish your website to see the 
results displayed.. 
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The RSS Subscribe Button 

You can add an RSS Subscribe button to your website so that your visitors can 
easily keep up to date with your blogging. 

To add an RSS button just use the Insert-> Button-> RSS Subscribe menu.  

Select from the menu to either subscribe to the website project’s blog using 
‘Select Blog’ or from another location using the ‘Enter URL’ option (see Figure 
41). 

Your button will be placed on the web page so that your visitors can subscribe 
to your blog using RSS. 
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Figure 41: The RSS Subscribe Button lets your visitors subscribe to your blog
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Previewing Your Website 

Whilst you are building your website and before you publish your website to 
the Internet, it’s a good idea to preview your web pages to see how they will 
look before going live. 

It’s also a good time to test out some  the features of your website such as the 
navigation and hyperlinks.  

Preview takes advantage of the browsers installed on your computer. On a mac, 
Safari is installed but it is recommended that you install other browsers such as 
Google Chrome, Opera, Firefox etc, in your mac’s Application folder so that you 
can test your website in as many different browsers as possible before 
publishing 

To preview your website, click on the Preview button in the 
Toolbar. You will see a list of all of the browsers that have been 
installed on your computer. Select the browser of your choice. 
EverWeb will process your website files then preview the results 
in your browser. 

You can test out most features of your website in Preview. Please note that 
some features may not work as they e.g. Contact Forms, as they may require 
publishing to the Internet in order to work properly. 
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Preview Server 
EverWeb uses a Preview Server so that 
you can preview your website on any 
device that is attached yo your local 
network.  

To use the Preview Server 
functionality, go the the EverWeb-> 
Preferences-> General tab.  

Make a note of the HTTP address in 
the ‘Remote URL’s’ section. 

Preview your website on your 
computer using the Preview button in 
the Toolbar. 

Next, go to another device on your 
local network e.g. an wifi connected iPad. Open your browser and enter the 
Remote URL’s address that you noted earlier.  

You will see an Index page. Select the second item in the list which has the 
same name as the page you previewed on your computer. You will see the 
same preview on your iPad as you on your computer. 

Caution 

Some web browsers such as Google Chrome do not support this functionality 
fully. If you use Google Chrome as your default browser it is recommended that 
you turn off EverWeb’s Preview Server. You can do this in the EverWeb-> 
Preferences-> General tab (See Figure 42).  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Figure 42: EverWeb ’s General Preferences showing 
Preview Server.
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Publishing Your Website 

When you are ready to publish your website in EverWeb, click on the Publish 
button in the Toolbar.  

If this is your first time publishing in EverWeb, you will see a popup window 
appear. Sign in to your EverWeb account in order to publish your website. (See 
Figure 43). 

If you do not have an EverWeb account and want to create one, click on the 
‘Create Account’ button to register an account. 
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Figure 43: Log in to your EverWeb account in order to publish 
your website.
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If you have an EverWeb account, you can click on the Sign In button, which will 
bring up the Preferences window (see Figure 43).  

In this window, you will be able to enter your EverWeb email login and 
password. When you are done, click on the Sign In button. 

Once you are signed in to your EverWeb account, you will not need to enter 
login information again unless you Sign Out. 

Once logged in, click on your website name to view the Publishing Settings. 
Under the Publishing heading, you can choose to publish to your EverWeb 
Hosting account, to a local folder or to a third party FTP server. 

If you are publishing to EverWeb, you will see the ‘EverWeb Location’ settings as 
shown in Figure 44. 
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Figure 44: Users publishing to their EverWeb Hosting account can select from their multiple 
accounts, and multiple domains, as applicable. 

everwebtutorials.com

domain2.com
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Under the Accounts drop down menu, you can choose which EverWeb hosting 
account you wish to publish to. You will most likely only have one account so 
you can leave this as is.  

If you have more than one domain on the account, you will see a Domains 
drop down, which will allow you to choose which domain to publish to. If you 
only have one domain, you will not see this menu. 

 

The Subdirectory field (see Figure 45) allows you to publish your website to a 
different location on your server. 

The’Subdirectory’ location can be used for testing purposes before your website 
goes live. 
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Figure 45: The Subdirectory field allows you to publish your website to a different directory on the server. This is 
useful as you can publish to a temporary location for testing purposes without overwriting an existing website.
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For example, entering the word 'temporary' would publish the site to 

http://www.everwebtutorials.com/temporary 

rather than at  

http://www.everwebtutorials.com.  

The current website published at http://www.everwebtutorials.com would not 
be overwritten. 

If you want to publish your site without the Subdirectory, leave the 
Subdirectory field blank. 

When you are ready, click on the Publish button in the Toolbar, 
and EverWeb will publish your website. 
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Head and Footer Code 

You will notice that there is a field for Head and Footer code. This is an 
advanced feature that lets you add custom code that gets place within the 
Head section of your website or right at the bottom of your website. 

This is useful for adding Google Analytics, Statcounter.com or custom 
Javascript code. 

Adding Google Analytics 

The Footer field can be used to add your Google Analytics code. Just copy and 
paste your Google Analytics code to this field. 
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EverWeb + Hosting Accounts 
If you do not have an EverWeb account you can create one here.  

EverWeb+Hosting account pricing starts at $99.95 USD/year and provides web 
space and personal email addresses. It also provides free updates and support 
while your account is active. 

When you create an account you will be asked to make a password. This 
password, with your email address, is all you need to publish your website. 

Once your account is created enter your Email address in the ‘Email’ field and 
your password in the ‘Password’ field and click ‘Sign In’.  

Under the ‘EverWeb Location’ header you will see your website address (also 
known as your domain name) in the ‘Accounts’ drop down menu. It should be 
automatically selected for you. 

If you want to secure your website using end to end data encryption and 
receive a rankings boost from Google and other search engine providers, tick 
the ‘Use HTTPS Secure URL’s’ box. For more information about this, please refer 
to the ‘EverWebSite Shield Addon’ section at the start of the User Manual. 

The ‘Subdirectory’ field should only be used if you have multiple websites 
under one account. It lets you have a unique website address for each website 
and will prevent any websites from being overwritten. 

Tip: If you want to have multiple websites you don’t have to worry about your website being 
overwritten. Just enter a unique subdirectory for your second website. EverWeb will warn you if 
you are overwriting an existing website previously published through EverWeb. 
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Setting Up Personalized Email Addresses 
EverWeb makes it very easy to create and manage personalized email 
addresses. These emails addresses will use your domain name in them. 

 

To setup an email address to be associated with your domain name: 

1. Scroll to the bottom  of the Publishing Settings Screen. 

2. In the Email Addresses section (see Figure 46), click on the Add button. 

3. In the popup window, type in your desired email name and select the 
domain you want to associate it with from the drop down menu. If you 
only have one domain, you will not need to select the domain. 

4. Type in your desired password and then retype it to confirm. When you 
are done, click on the Create button. 

5. You should now see your email address in the list. 
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Using Email Addresses in Apple Mail 
If you want to configure your email address in Apple's Mail application, select 
the email address from the list and then click on the ‘Configure in Mail’ button. 

You will see a popup window letting you know that incoming and outgoing 
email settings were successfully setup. Press the ‘OK’ button. 

Now, open Mail, and you will see that your email address has been added. 

Tip: When you click on the Send Email button, you might see a Verify Certificate popup appear. 
You can either click on the Connect button to continue, or click on the Show Certificate button, 
and then check the option to ‘Always Trust’ the server when connecting your email. This is 
perfectly safe to do and we recommend it. 
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404 Not Found Page 
A ‘404 Not Found Page’ lets you assign a page in your website to display if a 
visitor tries to access a page that doesn’t exist.  

This usually happens if  

• There is an an outdated link on your website 

• If the user mistypes the web page name in the browser’s search box 
when looking for a page on your site 

• If you have updated your site and removed an existing page. 

Adding a page to your website to capture such instances makes your website 
more professional. It also help keep your visitors in your website. 

Create a ‘404 Error Page’ in your website to redirect the user to another page in 
your website.  

Remember to also create a page for your mobile website as well as your 
desktop website. 
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FTP Publishing 

EverWeb lets you publish your website to any web hosting provider by the FTP 
Server Publishing option. EverWeb supports: 

• FTP 

• FTP with SSL Protocol  

• FTP with SSH Protocol 
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To publish to your FTP Server,  

1. First access the Site Publishing Settings of your website Project using 
the File-> Edit Publishing Settings, or by clicking on the name of your 
website Project in the Web Page List. 

2. The Editor Window will now display your Site Publishing Settings 
(Figure 47). 

3. Set the ‘Publish To” location to ‘FTP Server’. 

4. Complete the FTP Server Details section. If you are unsure of your FTP 
publishing settings, please contact your web hosting provider who 
should provide these details. 

Username and Password Fields 

Remember to pay special attention to the username and password field in the 
FTP Server Details section. Your Hosting Provider may have set up a user 
account username/password for you and also a separate FTP login username/
password.  

Your Hosting user account lets you login to your Hosting Provider’s website to 
access billing and account details. 

In contrast, your FTP login details are used in EverWeb’s Site Publishing 
Settings. So remember to check that you are using the right login as using the 
wrong login can result in authentication errors when trying to publish. 

The other field to pay attention to is the Directory/Path field. This is the 
directory path to the location where your web page files are stored. The 
Directory/Path location can differ between web hosting providers. 
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If you are not sure of what to enter in this field, check with your Hosting 
Provider. An incorrect file path can cause your website to be published to the 
wrong location and not accessible via your web browser. 

Once you have entered in your FTP Server Details, you can use the ‘Test 
Connection’ button to check if the connection to your Hosting Provider’s server 
is working correctly. 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Publishing Preferences 
To improve the speed of publishing your website, you can take advantage of 
multiple connections from your computer to your Hosting Server.  

Use the ‘Maximum 
Connections’ drop 
down in the Publishing 
tab of the EverWeb-> 
Preferences menu to 
change the number of 
connections you want 
to use when publishing 
(see Figure 47). 

The more connections 
that are in use, the 
faster the publishing of 
your website. However, 
with more connection 
in use, publishing may 
become less reliable.   

The fewer connections 
will result in slower but 

more reliable publishing. 

Some hosting providers limit the number of connections that can be used, 
usually to around 5 connections. 
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Figure 47: EverWeb’s Publishing Preferences options, showing the 
‘Maximum Connections’ dropdown.
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