Jump to content


Photo

Analytics Code On Widgets


  • Please log in to reply
5 replies to this topic

#1 chriscampbell

chriscampbell

    RAGE Newbie

  • RAGE Members
  • Pip
  • 3 posts

Posted 29 March 2010 - 01:59 PM

Hi All

I am new to iweb and iweb SEO tool but find it a great resource, I just have on problem hopefully someone can help.

I have put google analytics code into the SEO tool but it puts this code onto to every HTML that includes code I have on my site from paypal in the form of a widget. Every time I get a hit on my web page the widgets are counted and so I get inaccurate information. I have tried to take all analytics information off the web site and do it page by page ( not the best solution but I could do it if necessary ) but SEO only allows me to put the google analytics code on all the pages or none at all. I have also tried to update the preference not to include the word "widget" or "markup" but this does not seem to work either.

If anyone can offer any advice it would be much appreciated

chris

#2 Jeremy

Jeremy

    RAGE Advisor

  • RAGE Admin
  • PipPipPipPipPip
  • 419 posts

Posted 29 March 2010 - 08:47 PM

If you don't press the Apply to Entire Site button, then the code will only be placed on the page where you put it on manually.

#3 chriscampbell

chriscampbell

    RAGE Newbie

  • RAGE Members
  • Pip
  • 3 posts

Posted 30 March 2010 - 02:26 AM

If you don't press the Apply to Entire Site button, then the code will only be placed on the page where you put it on manually.



when I press the apply button the code automatically goes onto all the pages including the widgets even though it says it is only puting the code onto the page I have selected ?

#4 RageSW

RageSW

    Administrator

  • RAGE Admin
  • PipPipPipPipPip
  • 2,082 posts

Posted 30 March 2010 - 11:27 AM


If you don't press the Apply to Entire Site button, then the code will only be placed on the page where you put it on manually.



when I press the apply button the code automatically goes onto all the pages including the widgets even though it says it is only puting the code onto the page I have selected ?


Hi,

Export your website once again for iWeb and try using the Apply button on the newly exported site.

#5 chriscampbell

chriscampbell

    RAGE Newbie

  • RAGE Members
  • Pip
  • 3 posts

Posted 31 March 2010 - 05:34 AM



If you don't press the Apply to Entire Site button, then the code will only be placed on the page where you put it on manually.



when I press the apply button the code automatically goes onto all the pages including the widgets even though it says it is only puting the code onto the page I have selected ?


Hi,

Export your website once again for iWeb and try using the Apply button on the newly exported site.




Hi

Thanks I tried this and SEO is still putting the code on every page even though I am trying to put the code just onto one page at the time. It is putting the code onto widgets as well ???

Chris

#6 RageSW

RageSW

    Administrator

  • RAGE Admin
  • PipPipPipPipPip
  • 2,082 posts

Posted 31 March 2010 - 06:20 PM




If you don't press the Apply to Entire Site button, then the code will only be placed on the page where you put it on manually.



when I press the apply button the code automatically goes onto all the pages including the widgets even though it says it is only puting the code onto the page I have selected ?


Hi,

Export your website once again for iWeb and try using the Apply button on the newly exported site.




Hi

Thanks I tried this and SEO is still putting the code on every page even though I am trying to put the code just onto one page at the time. It is putting the code onto widgets as well ???

Chris


Hi Chris,

I am not sure why this is happening for you because it works ok for me. Maybe you don't have the latest version?
http://www.ragesw.com/products/iweb-seo-tool.html

1. Open your new site in iWeb SEO Tool

2. Enter your analytics code

3. In your preferences make sure you have the proper restrictions to skip files with widget in their names. This is default.

4. Press the Apply to entire site.

There is no way for the Apply button to add your code to all your pages. The code must have already been on them from pressing the Apply to Entire Site button.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users