How To Embed A Forum On An iWeb Website

August 12th, 2011

Ever wanted to add a forum to your iWeb website? Well now you can. This quick tutorial will show you a very easy way to add a forum to an iWeb website. Also see our post on how to add a mailing list signup form to an iWeb website.

Video Transcript:

In this tutorial, I am going to show you how you can easily add a forum to your website in iWeb.

The first thing we’re going to do is open our web browser and go to

Next, click on the Start a Free Forum button. Type in a username that you want to use on the forum, and enter your e-mail address and a password.

Then think of the name that you want to give to your forum. Don’t worry too much about making the perfect name as you can easily change this later on.

You can put a description in if you want, otherwise leave it blank and type in the Captcha, and then press Create Forum.

When you are done, you will be taken to your forum. You will need to then open the confirmation e-mail that you will be sent, and then click to confirm. When you have been confirmed, your forum will look something like this.

Next, click on Options, and then select Embedding Options. Now highlight this embed code that you are given, and copy it.

Now let’s open up our sites in iWeb. Add a page by clicking Add Page, and selecting your template and then highlighting the Blank page and pressing the Choose button.

Delete the text box that says Text in it. Drag the HTML Snippet widget onto the page, and paste the embed code that we just copied.

Adjust the snippet so that the forum fits nicely on your page.

When you publish your site, your forum will be live and your users can begin having discussions.

2 Responses to “How To Embed A Forum On An iWeb Website”

  1. Steve Says:

    The embed code that they generate is wrong… It’s got an extra “http://” in it. Once you remove it, works fine!


  2. fede Says:

    When I publish the website obtain this error:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Apache/2.2.11 (Unix) PHP/5.2.17 Server at Port 80

Leave a Reply